vNextTrain/3G対応

このページを編集する    
※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

3GC対応状況



機種 2/3G 2/14公開版 2/21テスト版 3/6テスト版
V602SH 2G
V902T 3G × × ×
V902SH 3G × ×
V903T 3G ×
V703N ? × ×

課題

  • 3GC機にインストールできない
    • 発見日 2006/02/19
    • 解決日 2006/03/12
    • 状態:close
    • 現象:ver. 1.2.6を公開した後、vNextTrain掲示板に中村様より報告あり。
 対応ありがとうございます。
 しかしアブリをダウンロード中に不正なアブリですと
 表示されてしまいました。
 使用機種は902Tです。
    • 原因の想定
      • 3Gになり、jadファイルの表記方法が変更になったから? http://bluegraph.fc2web.com/appli.htm
      • MIDlet-Descriptionの記述が長すぎるとDL時にはじかれるそうだが、これは記述していないので関係無いか。 http://memories.cocolog-nifty.com/diary/cat3018936/index.html
      • 上記URLに、開発の手引 3GC編とあるが、Vodafone Developpers Siteには、該当しそうなドキュメントのダウンロードリンクが無いように見える?→「VFX対応端末編」に記載あり。
      • MIDxlet-APIの指定バージョンがJSCL-1.2.2ではなく、JSCL-1.1.0だから? これは起動時にエラーになるそうで、ダウンロード時のエラーとの報告ではない(ひよこめもりーずの報告から)。原因とは考えにくい。
      • JADファイルの改行コードの問題?
      • MIDlet-Jar-Info, MIDlet-Install-Notify, MIDlet-Delete-Notifyは、JAD記載必須という表記が「VFX対応編」にあった。
    • 情報収集
      • 中村様の御協力の下、実機テストを実施する。
      • vNextTrainのサイトで情報提供を呼びかける。
  • 原因
    • JADファイルとManifestファイルのMIDlet-1プロパティの記述が異なっていた。
      • 大文字と小文字の違いを3Gではチェックする。
      • アイコン名の省略も問題?
    • 「まるくん」様の御協力で解決!多謝!

JADファイルの内容(2/21版)


MIDlet-Vendor: Susumu
MIDlet-Name: vNextTrain
MIDlet-Version: 1.2.6
MIDlet-1:  vNextTrain,vNextTrain.png,shin.midlet.vnt.vNextTrain
MIDlet-Jar-URL: vNextTrain.jar
MIDlet-Jar-Size: 0
MIDlet-Application-Range: 0,0
MIDxlet-Screen-Size: 0,0
MIDlet-Data-Size: 20000
MIDlet-Icon: vNextTrain.PNG
MIDlet-Network: Y
MIDlet-Resident: Y
MIDxlet-Resident: Y
MIDlet-OCL: JSCL-1.1.0
MIDxlet-API: JSCL-1.1.0
MIDlet-Permissions: javax.microedition.io.Connector.http
|新しいページ|検索|ページ一覧|RSS|@ウィキご利用ガイド | 管理者にお問合せ
|ログイン|