gccで-lzオプションがありませんエラー


※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.0.3/../../../libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.0.3/../../../libz.a when searching for -lz
/usr/bin/ld: skipping incompatible /usr/bin/../lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /usr/bin/../lib/libz.a when searching for -lz
/usr/bin/ld: skipping incompatible /usr/lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /usr/lib/libz.a when searching for -lz


64bit環境でzlibがらみのトラブル。自分はpyInstallerで発症。
yum install zlib-devel
で直りました。
ツールボックス

下から選んでください:

新しいページを作成する
ヘルプ / FAQ もご覧ください。