初心者もOK! FreeBSD質問スレッド まとめサイト @Wiki portsはどれをインストールするべき


※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

portsはどれをインストールするべき

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
FreeBSDを触ってみようと、VMWareにインストールしてみました。
インストールが完了したあとports(?)かなんかで
オプションでいろいろインストールするの選べますよね?
ずらーっと並んでるんですが、どれをインストールするかわかりません。
皆さんはパッケージ(?)の名前とかを見ただけで、
それが何かとかわかるのでしょうか?
それともそのパッケージがどういうものかというのを、
1つ1つ調べてるのでしょうか?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
答えの例
(1)ケースバイケース
(2)使うものなんか決まっているので選ぶだけ
(3)依存関係で余計な物を入れられるのは嫌なのでports/packagesは
 使ってない
(4)ここで調べる
 http://www.jp.freebsd.org/www.FreeBSD.org/ja/ports/
(5)使いたいものをぐぐってから/usr/ports/で grep hogehoge INDEX-6
 してますが何か?


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
(5)訂正
× grep hogehoge INDEX-6
○ egrep '^hogehoge' INDEX-*


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
最初にportsをインストールしなくたって、FreeBSDは触れるじゃない。
操作になれて、何かやってみようと、思った時でも遅くはない。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >413
簡単な説明がその画面の下に出ているはず。
基本はどれも入れなくていい。
後からでも入れられるし。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
まず何がしたいのかをはっきりさせないと
どれをインストールしていいかわからないのは
当たり前だと思う。

したいことに応じて、インストールすべきものの候補が挙がり
その中で自分の目的にふさわしいものを選ぶ。
って段階をふめばいいんでないの。

まあ、全てのportsをインストールして使用感を試すってのが
目的なら話は別だけど。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
全てを試したら、終わるころには7.0-STABLEとか出てそうだ。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
システム付属じゃ足りないから追加インストールするのでは?
何が足りないか?わからない内は、ports/packageなんて気にする必要なし。
ふつうは、日本語関係のものをかたっぱしから入れる。
jman, jman-doc, jlessなど

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
皆様レスどうもありがとうございます。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >414
参考サイトありがとうございます。
あとでしっかり読みたいと思います。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >416-417
英語が苦手なので読み飛ばしてました…。
必ずしもportsをやらなくてもいいんですね。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >418
アドバイスありがとうございます。
とりあえず一通り操作をして、慣れてきたら
サーバでもいれてみたいなと思っています。
まずは何もいれないでいろいろ触るところからはじめていこうと思います。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >420
なるほど。そういうことだったんですかぁ。
心強いお言葉ありがとうございます。気にしないでいこうと思います。

昔cygwinをいじっていたので、bashだけ入れてみたいと思います。
どうもありがとうございました。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >421
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 英語が苦手なので読み飛ばしてました…。
英語がにがてなら、オンライン英語辞書ソフトを入れるとかと言うふうに考える。
ログイン画面の英語は、初心者にとっていいこと書いてあるから
がんばって読んでみては?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
インストール時のパックアゲは古いからcvsupしか入れね

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
インストール時にはportsは入れずに、
ports.tar.gzを取ってきて展開するのが好み。


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >428
portsnap つかえ

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >429
えー

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 429
各ミラーからports.tar.gzを持ってくる方が負荷が低いでしょ。
あとおれはportsnapのサーバーは日本野良ミラーを指定している。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
portsnapのミラー立てたいね。
どうすればいいんだろう。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
portsnapの野良とか理念的にありえないんだけどね・・・・・・

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
http://cvsup.pt.freebsd.org/cgi-bin/cvsweb/cvsweb.cgi/projects/portsnap/pmirror.sh
http://www.allbsd.org/~hrs/diary/200601.html#d2703