初心者もOK! FreeBSD質問スレッド まとめサイト @Wiki acroreadをバージョンアップしたらfirefoxでpdfのプラグインが使えない

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

acroreadをバージョンアップしたらfirefoxでpdfのプラグインが使えない

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
japanese/acroreadをハ゛ーシ゛ョンアッフ゜したら、firefoxでpdfのプラグインが使えなくなった。
(about:pluginsをアト゛レスにしても出てこない。)
/etc/libmap.confは、テンフ゜レのをコピーしただけ。
何か、特別な設定が必要?シンホ゛リックリンクかと思ったけど、わからん。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >626
acroread自体、起動できるのか?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >627
yes

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 626>628
確かに japanese/acroread はバージョンアップで firefox等のプラグインが動かなくなったようだ。
firefox を動かして about:plugins を表示すると、
ログに
LoadPlugin: failed to initialize shared library /usr/X11R6/Acrobat7/Browser/intellinux/nppdf.so
[/usr/X11R6/Acrobat7/Browser/intellinux/nppdf.so: Undefined symbol "__ctype_b_loc"]
などと出る。
調べてみると
fopen64
readdir64_r
__strtod_internal
__strtof_internal
__strtold_internal
__strtoll_internal
__strtoull_internal
__ctype_b_loc
__ctype_get_mb_cur_max
__ctype_tolower_loc
__ctype_toupper_loc
__xstat64
が軒並み Undefined symbol ですね。

linuxpluginwrapperのバージョンアップを待つのがいいと思います。



html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >652の続きです。自分でなんとかやってみようとした。
compat_glibcの中をいじればいいとわかり、
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 fopen64
はやってみた。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 __strtod_internal
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 __ctype_b_loc
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 __ctype_tolower_loc
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 __ctype_toupper_loc
当りもなんとかできたけど
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 __xstat64
がわからない。なんだか64というからには64bitOSでも
できるようになってるのか知らないけれどその変がさっぱり。
やっぱり作者さん頼み
しかないのかなぁ。


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >664
さっき全て新規でfirefox + linuxpluginwrapper + acroreadをインストールしたんだが普通に動いてるぞ。