初心者もOK! FreeBSD質問スレッド まとめサイト @Wiki "."から始まるファイルをroot以外かつwheelグループのみで可視にするには

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

"."から始まるファイルをroot以外かつwheelグループのみで可視にするには

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
"."から始まる不可視属性ファイルをroot以外で可視状態にするには
どうすれば宜しいのでしょうか?
できれば、wheelグループのみ可視状態にしたいのですが…

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >851
「不可視属性」って何?


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >851
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 "."から始まる不可視属性
なんてものは持ってないんですよ, Unix 系の OS は...
シェルとか ls 等のコマンドが, "."から始まるエントリを表示していないだけ.
ls が root で見えるのは自分で uid 見て 0 だったら "." から始まるファイル
を表示しています.
sh なり csh なり ls なり... のコマンドを gid が 0 だったら "." から始まる
ファイルも表示するように自分で改造してください.


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >853

難しいこと言わないで

ls -a

で見られるよ

って教えてやれよ


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >854
そぉ言うレベルの問題なのか?


html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
ls -aしなくてもデフォルトで見えるようにしたい、という質問だろ。
ちなみに、rootでls -aがデフォルトになるのは *BSD の lsだけだよ。
SolairsやGNU lsでは rootでも特別扱いしない。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >853-855
最近だとlsじゃなくてGNOMEとかKDEのファイラー?から見えるかどうかじゃないの?

どっちにしても>>851の文章が、主語と目的語がはっきりしなくて困る。。。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
お前等釣りだと気付けよ。

「root 以外」&&「wheel」で可視

だぞ?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
rootをwheelグループから外すと、どうなりますか?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >858
rootだけではなく、wheelでも。って意味かと。