初心者もOK! FreeBSD質問スレッド まとめサイト @Wiki portupgradeしたらgnomeが使えない

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

portupgradeしたらgnomeが使えない

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
6.0を再インストールしてX関係のソフト(gnome、scim-anthy、firefox、etc・・・)をportsからインストールしました。
その後、portsツリーのアップグレードをするのを忘れていたのに気がつき
アップグレードした後
portupgrade -aを実行しました。するとgnomeが起動しなくなりました。

/var/log/Xorg.0.logは
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: SetupAuto: hw.iftype is 4, hw.model is 0
(II) Mouse0: SetupAuto: protocol is SysMouse
FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, should be 1; fixing.
となっていました。

.xinitrcを.xinitrc-aaaとしてみるとXは起動するのでgnomeが原因だと思います。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
そうなんですか。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >904
情景や感情がよく伝わってくる作文ですね。よくできました。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >905>>906
ありがとうございます。情景や感情がうまく伝わってうれしいです
できれば解決方法も教えてもらえるとありがたいです。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
/usr/ports/UPDATING

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >904 を読んで
904を読んで、この作文の作者さんはこの作品を通じて、
gnomeが原因だということを言いたかったのだと思います。
作品の中では、リアルなエラーメッセージが綴られており、
読んでいる私も思わず興奮してしまいました。
作者さんの思惑どおり、原因がgnomeであることを私も願います。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
要は、古いportsツリーから、portsをインストールして、
後から、それが古かったってことで、portsツリーを最新に同期して、
portupgradeでアップグレードしなおしたって事でしょ?

で、その結果、GNOMEが起動しなくなった。GNOMEをportupgradeを使って、
更新しちゃ駄目よって事は、/usr/ports/UPDATINGに書いてあるから、
てっきり、その問題を確認して報告してくれただけかと思った。
悩んでたのなら、意地が悪かったかも知れない。すまん。

思うに、今からだと、GNOME関連のportsを削除した後、ビルドしなおした方が
確実なんじゃない?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >908>>910
ありがとうございます。
GNOMEをportupgradeで更新してはいけないってことははじめて知りました。
GNOME関連のportsを削除&再インスコしてみます。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >910
そういうことされるの覚悟で質問したので別に気にしてないですよ。