初心者もOK! FreeBSD質問スレッド まとめサイト @Wiki phpをアップグレードしたらUndefined symbol getopt_long

※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

phpをアップグレードしたらUndefined symbol getopt_long

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
今日いつものようにphp周りの更新があったのでportupgrade -aで一通りうpして
apachectl gracefulすると、Cannot load /usr/local/libexec/apache2/libphp4.so
into server: /usr/local/libexec/apache2/libphp4.so: Undefined symbol "getopt_long"
とでてきたので、/usr/ports/lang/php4でmake clean installと再インストールを試みるも、
ext/standard/basic_functions.lo(.text+0x14bf): undefined reference to `getopt_long'
とでてきてしまいました。これってどうすればいいんでしょうか?
FreeBSD4.11+php4.4.2_1,1+apache2.0.55_2(全てports)です。よろしくお願いします。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >119
http://lists.freebsd.org/pipermail/cvs-ports/2006-January/086116.html

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >121
これは具体的にMakefileのどこをいじればいいんでしょうか?
すいません、いまいちわからないです。

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >129
ports から入れたんだろ?
だったら、cvsup するなり portsnap するなりすれば?

html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。
html plugin Error : このプラグインを使うにはこのページの編集権限を「管理者のみ」に設定してください。 >133
あ、再度csvupすればよかったんですね。直接いじるのかと思ってました。
無事できました。ありがとうございました。